ext-curl is missing in composer.json

Selepas upgrade kepada PHPStorm 2018.2 aku mula mendapat notis ini kepada kod yang menggunakan curl_ dan juga notis ext-json jika menggunakan json_. Setelah aku baca dan tanya pendapat orang lain, jika dan hanya jika keperluan tersebut adalah penting (sistem tak jalan betul kalau tak ada, bukan pilihan) maka letak.

ext-curl is missing in composer.json
contoh notis ext-curl tiada di dalam composer.json

Tujuannya adalah untuk memastikan persekitaran pelayan yang kita jalankan sistem tersebut memenuhi keperluan minima sistem kita. Maka tambah sahaja dan akan menjadi satu perkara wajib untuk semua sistem yang aku guna selepas ini.

"require": {
        "php": ">=5.6.4",
        "ext-curl": "*",
        "ext-json": "*",

Tambah sahaja baris baharu ke dalam fail composer.json dan selepas itu patutnya notis tersebut akan hilang.

Atau boleh buangkan pilihan untuk keluarkan notis tu daripada penetapan PHPStorm tapi, apa guna kau buat kerja dalam IDE kalau semua notis buang?

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.